Symptoms

The following error occurs when I try to open a site in Wizard, publish a site, or create a new snapshot in Web Presence Builder:

Unable to connect to Web Presence Builder. Please contact the server administrator.

or

Cannot connect to Parallels Presence Builder Server. Please contact the server administrator.

or

Invalid response from server

Cause

  1. You have exceeded the PHP limits on the domain where the site is published.

  2. A timeout occurred while the Apache web server was waiting for a response from PHP CGI.

  3. [For OA customers] There is a large number of files in this website; the task to publish the website fails with a timeout.

  4. [For Plesk users] There is a low memory_limit in the PHP configuration of Plesk Panel: /usr/local/psa/admin/conf/php.ini

Resolution

  1. Increase PHP limits for the domain where the site is published. The following PHP limits are recommended:

    max_execution_time = 600
    memory_limit = 192M
    post_max_size = 2147483647
    upload_max_size = 2147483647     
    
  2. Reconfigure TIMEOUT in /etc/httpd/httpd.conf or for Web Presence Builder for Plesk Automation, add TIMEOUT to /usr/local/pem/etc/apache/httpd.conf_pem.override.

    Note: Copying the site to Facebook greatly increases the amount of time it takes to compile and publish the site (by 30 to 50 percent). Try disabling site copying to Facebook through the main menu:

    Settings > Social Media > Show a copy of my site on Facebook
    
  3. [For OA customers] Refer to this KB article for more details.

  4. [For Plesk users] Increase memory_limit in /usr/local/psa/admin/conf/php.ini.

Additional information

[WPB 11.0 in OA/Plesk/STD] Cannot publish site: "Unable to connect to Web Presence Builder server"

[WPB in OA] Customer cannot publish Web Presence Builder site: "Unable to connect to Web Presence Builder server"

Internal content

Link on internal Article