Symptoms

The process of opening a site in Web Presence Builder hangs on step two:

Please wait. 
Step 2 of 3: Loading website structure...

The following error appears about two minutes after attempting to publish the site:

Unable to connect to Web Presence Builder server. Please contact the server administrator.

The following error can be observed in /var/log/sw-cp-server/error_log:

2014/03/26 16:24:25 [error] 29586#0: *1948357 upstream timed out (110: Connection timed out) while reading response header from upstream, client: 91.204.25.4, server: , request: "POST /sitebuilder/JsonApi/ HTTP/1.1", upstream: "fastcgi://unix:/var/run/sw-engine.sock", host: "10.10.01.10:8443", referrer: "https://10.01.01.10:8443/sitebuilder/Editor"

Cause

This is a software issue, #PPPM-1541, which will be fixed in future Web Presence Builder updates.

Resolution

There are three different ways to resolve the issue:

  • Ideally, you should upgrade Web Presence Builder 11.0.8 to version 12.0.6. The site management scheme has been improved significantly since version 11.5.
  • You can increase PHP limits according to this Knowledgebase article: https://kb.cloudblue.com/en/117909
  • For versions of Web Presence Builder higher than 11.5, remove surplus pages from the site to make it smaller.

Additional information

As of version 11.5, the number of pages per site is limited to 500. To increase site performance, you may decrease the page limit in the configuration file (/usr/local/sb/config):

[general]
maxPagesNumber = 400

By default, the limit is set to 500.

IMPORTANT: Do not change the limit to more than 500.

Internal content

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