Symptoms

  • There is an order in one of the statuses 'Completed' (CP), 'Waiting for Payment' (WP) or 'Ready to Complete' (CR) but one of the provisioning items is in Failed status.
  • The order log shows that an order has been in Manual Operation required (MO) status.

Cause

The situation described above may happen under following circumstances:

  • the provider's staff member found an order in the 'Manual Operation Required' (MO) status in PBA control panel and manually completed the provisioning item by clicking 'Mark as Completed' button. This made an order being processed further in accordance with the order flow, so an order reached one of the statuses 'Completed' (CP), 'Waiting for Payment' (WP) or 'Ready to Complete' (CR);
  • the provider's staff member clicked 'Back' button in the browser;
  • the provider's staff member clicked 'Mark as failed' for the same provisioning item, which resulted in its status change to failed.

The logs can confirm if that is true (Apache or IIS logs, and logs of the WWW container on PBA application server).

To prevent possibility of changing the status of a provisioning item several times the request PBA-50404 was created.

Resolution

To complete an order manually, trigger an appropriate event:

Home> Configuration Director> Event Manager Settings> Event Types

If that was an item for resource provisioning, trigger an event Upgrade Completed with the parameters

OrderItemID=<needed_ID>; IssuedSuccessfully=1; Message=Done; GateID=2

If that was a subscription provisioning, trigger an event Creation Completed with the parameters

OrderItemID=<needed_ID>; SubscrID=<subscription_ID>; IssuedSuccessfully=1; Message=<message>

needed_ID can be found in the Provisioning Items tab in the order.

If the item is for some other operation, please contact Parallels Support Team for a proper event triggering.

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