Symptoms

A POA task to provision a Windows-based service through the HMC Provisioning System (MPA, Microsoft Provisioning System) fails with the error message Failed while instantiating provider object associated with Namespace.

More detailed diagnostics is provided below:

Exception during execution of MPF request: 'Unknown error 0xC2201001
[<response><errorContext
description="Failed while instantiating provider object associated with Namespace = 'Powershell Provider'
with CLSID = 'Microsoft.Provisioning.Providers.PowershellProvider.PowershellProvider'
with Error Code='0x80131040'" code="0xc2201001" executeSeqNo="0">
<errorSource namespace="Powershell Provider" procedure="ExecuteCmdlet"/>
<errorSource namespace="SW Managed Exchange" procedure="CreateDisclaimer"/>
</errorContext></response>]'.

Note that the name of the failed Namespace (or HMC Provider), PowerShell Provider in the example above, may be different in different failed tasks.

Cause

The MPS (Microrosft Provisioning System) server stuck or the HMC Provider mentioned in the failed POA task is not properly installed on the MPS server.

Resolution

First, try to restart MPS service using the instructions in the Knowledgebase article #1851 How to restart MPS Provisioning Engine properly.

Check that MPF groups are members of local Administrators group:

  • [DOMAIN]\MPFServiceAccts
  • [DOMAIN]\MPSExchangeAccts
  • [DOMAIN]\MPSPrivAccts
  • [DOMAIN]\MPSSQLService

If the failed task does not go through after MPS restart, then reinstall the broken provider on the MPS server:

  1. Log in to the MPS server by RDP.
  2. Run the MPS Deployment Tool: Start > All Programs > Microsoft Hosting > Deployment Tool > MPS Deployment Tool.
  3. Find the needed provider, e.g., PowerShell Provider.
  4. Right-click and choose Uninstall.
  5. Click the Start Deployment button.
  6. Wait until deployment is finished.
  7. Find PowerShell Provider again.
  8. Right-click and choose Install.
  9. Click the Start Deployment button.
  10. Wait until deployment is finished.
  11. Restart the MPS engine per the instructions in the Knowledgebase article https://kb.cloudblue.com/1851
  12. Restart the failed task in POA Task Manager.

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