Symptoms

Vendor cannot add new user for customer account in PBA-E Control Panel at Top > Operation Director > Account Manager > Customers > choose account > tab 'Users', operation fails with error like this:

The record with code (1001234, 5123) already exists in the table Roles of User.

However the table 'UserRole' in PBA-E database does not contain these entries.

Cause

The reason of problem is that account has no users at all.

PBA-E behaviour:

  • When the very first user is created for an account PBA-E automatically creates a "Full Access" role and assigns it to this new user
  • The user creating wizard creates a user (and assigns "Full Access" role to it), then assigns all the roles selected on the last screen of the wizard As a result we have error, transaction is rolled back, and if we now select information from PBA-E database we can see neither user nor the record in the table "UserRole".

The issue is considered to be a software issue PBA-43571 and it is fixed in PBA-E 5.5 version.

Workaround

  1. Create one more 'Dummy' role for this account. It can be empty, without any privileges
  2. Creating new user select only this 'Dummy' role on the last screen of the wizard
  3. As a result user will be created and both 'Full Access' and 'Dummy' roles will be assigned to it
  4. After that you can detach 'Dummy' role from user and delete it (role) from the system.

Internal content