Symptoms

Windows service provisioning tasks through the Microsoft Provisioning System (MPS) are running indefinitely, or they keep failing with an error message such as:

No provisioning engine available

Unable to find any suitable MPF client nodes

The RPC server non available

No provisioning engines are available to process the request

The remote procedure call failed and did not execute

Also, sometimes it is not possible to restart the MPS engine from the Operations Automation (OA) Provider Control Panel (PCP) at Deployment Director > Server Manager > Hardware Nodes > (Select MPS server) > Applications > MPSEngine.

Cause

The MPS engine uses too much memory and blocks or delays task execution. The only way to work around the problem is restarting the engine.

The engine should not be restarted by killing the dllhost.exe process running under the MPFServiceAccts account. This is not safe and, if a transaction is running, data may become inconsistent because an instant kill with no rollback is performed.

Resolution

To restart the MPS Engine:

  1. Log in to the MPS node as the local or domain administrator.

  2. Stop the OA Agent using the net stop pem command in cmd.

  3. Run the dcomcnfg utility (Start > Run > dcomcnfg).

  4. Navigate to Component Services > My Computer > COM+ Applications in the left panel.

  5. Right-click on Provisioning Engine in the right panel and select Shutdown from the contextual menu.

  6. Wait until there are only two "dllhost.exe" processes in the Windows Task Manager. Verify that there are no "TraceView.exe" processes in the Task Manager.

  7. Right-click on Provisioning Engine in the right panel and select Start from the contextual menu.

  8. Start the OA Agent using the net start pem command in cmd.

Additionally, ensure that DNS servers on MPS node are set properly and point to Active Directory DNS servers.

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