Symptoms

A task to upgrade a Plesk in VPS Panel instance fails with the error:

    "code": 500,
    "type": "Rest\\RestException",
    "message": "Connection error: \"Failed to connect to 203.0.113.2 port 6308: Connection timed out\n\". Was trying to connect to \"https://203.0.113.2:6308/aps/2/application/\".",
    "stacktrace":
    [
            "#0 /usr/local/aps/ebd8c50e-faa5-4d6f-955e-717e381c88f7/vendors/aps-php-runtime/aps/2/apsc.php(767): APS\\Proto->sendRequest('GET', 'aps/2/applicati...')",
            "#1 /usr/local/aps/ebd8c50e-faa5-4d6f-955e-717e381c88f7/vendors/aps-php-runtime/aps/2/types.php(100): APS\\ControllerProxy->getApplicationServices()",
            "#2 /usr/local/aps/ebd8c50e-faa5-4d6f-955e-717e381c88f7/vendors/aps-php-runtime/aps/2/runtime.php(334): APS\\TypeLibrary::retrieveApplicationServices()",
            "#3 /usr/local/aps/ebd8c50e-faa5-4d6f-955e-717e381c88f7/vendors/aps-php-runtime/aps/2/runtime.php(389): APS\\Loader->handleHttpRequest()",
            "#4 /usr/local/aps/ebd8c50e-faa5-4d6f-955e-717e381c88f7/vendors/aps-php-runtime/aps/2/runtime.php(401): APS\\Loader->process()",
            "#5 [internal function]: APS\\Loader->__destruct()",
            "#6 {main}"
    ],
    "error": "ApplicationUnknownError",
    "http_request": "POST /vps/api/environments/93281061-550b-49d3-964c-feaeec9634e7/application/proxy/panels"

}

where 203.0.113.2 is the public IP address of the OA Management Node.

It is not possible to connect to this IP and port 6308 from the VE where Plesk is installed:

root@server-1010101-1:~# telnet 203.0.113.2 6308
Trying 203.0.113.2...
...no response...

Cause

Network limitations prevent the connection required for the application to be upgraded properly.

Resolution

Make sure the VPS in question is able to connect to the OA Management Node public IP and port 6308.

Internal content