Symptoms

After Odin Automation upgrade to 7.3, OSS Core node experiences high CPU and IO activity and degraded performance.

/var/log/pa/core.log size grows extremely fast.

The following messages appear in the log file repeatedly:

Feb 25 22:07:29.111 : DBG [bss-synchronizer-task:137358 EJB-default---7:1017 pau]: c.o.o.b.s.s.e.SynchronizerBean Error during synchronization id: 34603. Couldn't synchronize Account with id 1000010. Could not find PAAccount with accountId=1000010
Feb 25 22:07:29.111 : DBG [bss-synchronizer-task:137358 EJB-default---7:1017 pau]: c.o.o.b.s.s.e.SynchronizerBean Handling id: 34603 is finished with retry exception
Feb 25 22:07:29.117 : DBG [bss-synchronizer-task:137358 EJB-default---7:1017 pau]: c.o.o.b.s.s.e.SynchronizerBean Handling id: 34603, operation: CREATE, entity: ACCOUNT:1000010, uuid: 1b423204-3c6d-9fa1-89ad-4dbfd3dc17d3
Feb 25 22:07:29.117 : DBG [bss-synchronizer-task:137358 EJB-default---7:1017 pau]: c.o.o.b.s.s.e.NotificationsHandler Handling id: 34603, operation: CREATE, entity: ACCOUNT:1000010, uuid: 1b423204-3c6d-9fa1-89ad-4dbfd3dc17d3
Feb 25 22:07:29.125 : DBG [task:15792663 EJB-default---7:1017 pau]: c.p.p.s.a.e.AccountManagerBean finding account with id: 1000010

Cause

There is an account object present in Billing part and missing in Operations part of Odin Automation.

Such case handling is planned to be improved in scope of APS-44516.

Resolution

Contact Odin Technical Support for resolution.

Internal content

Link on internal Article