Symptoms

Reseller accounts were removed on OA side by API "per.removeAccount" and had "Cancelled" status on Billing side. After upgrade from OAP 6.0 to OAP 7.0 these resellers have been recreated and enabled in OA.

Cause

The issue occures due to the fact that during upgrade to OAP 7.0 Online Store API users are created for each reseller account and Online Store synchronization is performed. Synchronization process sends API call "pem.addAccountMember" to OA to create this user. But in case of account for this user is not found at OA side this account is recreated and enabled by this API. Synchronization of Online Stores for reseller accounts in status "Cancelled" should not be performed and caused by #PBA-84068 "Online Store status "Active" even for cancelled resellers".

Resolution

Please contact your Technical Account Manager or Pooled Technical Associate to clarify the status of #PBA-84068.

To workaround the issue with recreated reseller accounts the following actions could be performed:

  1. Disable newly created user at Billing side. It may be done from Billing Control panel in settings of required account on tab "Users"- "UserID" or via the following API request:

    "UserStatusChange_API"

  2. It would be better not to remove resellers at Operations side, but to disable it to avoid issue reappearance during further upgrades in case bug #PBA-84068 will not be fixed up to its time. Accounts may be disabled by the following API request:

    "pem.disableAccount"

  3. In case it is necessary to remove reseller accounts from OA side the following API may be used, but, please keep in mind that it may be required to repeat this procedure after next upgrade if issue #PBA-84068 will not be fixed:

    pem.removeAccount

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