Symptoms

Customer try to change Service plan for G-suite APS, an upgrade order failed with the following:

Jan 32 07:55:17  INFO   12345 Customer: 1011011:: Subscription:
1010101##Change plan from 1 to 2
Jan 32 07:55:17  INFO   12345 Customer: 1011011:: Subscription:
1010101##Upgrade subscription plan. Current plan ANNUAL, new plan
ANNUAL_YEARLY_PAY
Jan 32 07:55:19  ERROR  12345 Customer: 1011011:: Subscription:
1010101##Error upgrading subscription plan. Error message Error calling
POST
https://www.googleapis.com/apps/reseller/v1/customers/C00xxxx/subscriptions/1xxxxxxxxxx/changePlan: 
(400) Plan is either invalid or not applicable
Jan 32 07:56:25  INFO   13524 Customer: 1011011:: Subscription:
1010101##Change plan from 1 to 2
Jan 32 07:56:25  INFO   13524 Customer: 1011011:: Subscription:
1010101##Upgrade subscription plan. Current plan ANNUAL, new plan
ANNUAL_YEARLY_PAY
Jan 32 07:56:26  ERROR  13524 Customer: 1011011:: Subscription:
1010101##Error upgrading subscription plan. Error message Error calling
POST
https://www.googleapis.com/apps/reseller/v1/customers/C00xxxx/subscriptions/1xxxxxxxxxx/changePlan: 
(400) Plan is either invalid or not applicable
Jan 32 07:56:31  INFO   35142 Customer: 1011011:: Subscription:
1010101##Change plan from 1 to 2
Jan 32 07:56:31  INFO   35142 Customer: 1011011:: Subscription:
1010101##Upgrade subscription plan. Current plan ANNUAL, new plan
ANNUAL_YEARLY_PAY

Cause

Client have tried to switch Service Plan from ANNUAL (Annual Monthly) to an ANNUAL_YEARLY; this switch have failed. It failed because Google does not allow this, as this is documented in the G-Suite provider deployment guide page 47.

The Upgrade schema from APS documentation:

Resolution

Please, check attached upgrade schema from APS Documentation mentioned above, and perform only supported upgrades.

Internal content

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