Symptoms
On attempt to create an Office 365 Reconciliation Report from Provider CP
it fails:
"ERROR: canceling statement due to statement timeout"
billing.log
error:
[ BM_Object RQ8842835 TH23230 NTE] Finished method BM.OrderByStatusListGet_API(user = 1641813, SID = 0, lang = en, request = 8842835, localObject = 0, transaction = 14263479 (HP))
[ ADict RQ8842835 TH23230 NTE] Language::get("ERROR: canceling statement due to statement timeout") = NOTFOUND
i.e. OrderByStatusListGet_API
method fails by timeout.
Cause
Software-related issue #APSA-19360: "Reconciliation Report fails with "timeout" error under Provider account - botton threshold for OrderByStatusListGet_API is not set".
Resolution
Please contact pta@odin.com or TAM to trace the status of the issue.