Symptoms

Azure subscription provisioning fails with the following error:

The order provisioning has failed.
The last error - "Service Creation Failed: Operation Automation service was not created. Task "Provisioning "Tenant" for APS application Azure Cloud Solution Provider" (id = 12345678) is failed with error: "APS Application Error:
500 Internal Server Error
[unknown] Provisioning: resource b18e39e2-d353-4da3-8cc4-357a84bfa404 of type 'tenants' (http://www.odin.com/app/azure-csp/tenant/2.1) for APS application 'Azure Cloud Solution Provider-4.2-51': An unexpected error has occurred..
Body: {
"error": "unknown",
"message": "An unexpected error has occurred.",
"category": "unknown",
"http_request": "POST /azure/aps/tenants to '192.0.0.2:10443'"
}
"
Please check the "Provisioning item" (details) and the last items of the "Service Status History" (details) of the associated subscriptions for more details. As soon as you fix the problem, resubmit this order for provisioning.
Additional information about this error in Odin Knowledge Base - Click here to find a solution

The following error is represented in /usr/local/azure/site/log on Azure application endpoint :

2017-01-02 12:34:56,194 INFO  [com.odin.azure.api.AzureApi] (azure task-90) <CREST> Login to 'https://login.windows.net/123456b-123d-456b-78a9-123b45fa6a78/' as native client '123f4a567-1c23-4c56-7f89-fbda12a345e6' on behalf of 'customer@domain.com'
2017-01-02 12:34:56,533 ERROR [com.odin.azure.server.ErrorsHandler] (azure task-90) <APS-APP> Error: java.lang.IllegalArgumentException: Error when trying to form the request URI
        at com.microsoft.store.partnercenter.network.PartnerServiceProxy.buildPartnerServiceApiUri(PartnerServiceProxy.java:683) [partnersdk-odin-1.0.5.1.jar:]
        at com.microsoft.store.partnercenter.network.PartnerServiceProxy.get(PartnerServiceProxy.java:336) [partnersdk-odin-1.0.5.1.jar:]
        at com.microsoft.store.partnercenter.profiles.MpnProfileOperations.get(MpnProfileOperations.java:73) [partnersdk-odin-1.0.5.1.jar:]

Cause

Software-related issue APSA-19331. Reseller has a space symbol at the end of 'MPN_ID' parameter. This symbol is passed by Azure application to Microsoft Online causing the request error in the process.

Resolution

The issue is planned to be fixed in one of the future releases of Azure CSP application. Please contact your Technical Account Manager or Pooled Technical Associate (pta@odin.com) in order to clarify the current status of the issue.

As a workaround, the space symbol should be removed from MPN_ID parameter:

PCP > Resellers > Login under required reseller > Customer CP > General > Edit

In the field Microsoft Partner Network ID remove the space character at the end of the value and press Save

Internal content