Symptoms

Azure screen is not loaded when online store is shown in a frame of CCP (Home > System > Settings > Customer CP > Target(CCP v1) - correct link setup as described in https://kb.cloudblue.com/en/131730 > Main Frame)

In browser debug console an error can be seen:

DOMException: Blocked a frame with origin "https://store.domain.com" from accessing a cross-origin frame.

where https://store.domain.com is a link to the store, while link of the control panel is based on different domain, e.g. https://controlpanel.com

Cause

The redirect is blocked by the browser, which does not support the redirect from one domainname to a different one in a frame.

Resolution

Change the configuration.

  1. On the brand currently used enable store: System > Settings > Brands > brand and set the link to control.panel/store
  2. Change the url in BA: Home > System > Customer CP > New Subscription (CCP v1), use https://control.panel/store/index.php?redirect=HOME&operationType=login&Token=@@User_Token@ instead of https://store.domain.com/index.php?redirect=HOME&operationType=login&Token=@@User_Token@

It does not break anything on https://store.domain.com/, it will still continue working as before, just a different url https://control.panel/store/ (with the same content) will be loaded when buying new subscription from CCP. This is the only correct way to load the store in a frame.

Internal content