Symptoms

Accessing a Purchase Scenario, a screen with available Service Plans and Subscription Periods is not displayed. One of the Service Plans is automatically added to the cart, and there is no possibility to choose another one, desepite of the fact that several Service Plans are added to a Sales Category attached to the skipped screen.

Cause

A parameter SINGLEPLAN_EDIT is set to true on the respective screen parameters.

According to the parameter description:

When the CATEGORY_LIST_ID parameter lists only one sales category with a single plan. If SINGLEPLAN_EDIT is set to 'false', that single plan will be listed. If the parameter is set to 'true', the plan will be automatically added to the cart.

However the description is misleading: one of the Service Plans included into a Sales Category will be automaically added to the cart even if there are more than one Plan added to the resective Sales Category or Categories.

Resolution

A request #PBA-83233 "Update the SINGLEPLAN_EDIT option description in online store and guide" was submitted to update the parameter description.

If the described behavior is unnecassary for a screen, please, disable it via the steps below:

  1. Go Home > Products > Online Store
  2. Switch to Screens tab
  3. Find a screen which is skipped in a Purchase Scenario
  4. Click on Parameters button
  5. Choose the parameter SINGLEPLAN_EDIT
  6. Click Edit
  7. Set Value to false
  8. Click Save
  9. Synchronize the Online Store

Internal content

Link on internal Article