Symptoms
The steps: * Login on Provider's CP > Cloud Infrastructure > Virtualization Nodes > HW node > Cloud tab * Set node as "not ready to provide" * Press "configure Hardware"
lead to the error:
IP address XXX.XXX.XXX.XXX is already configured with id #XXX.
Example of the errors from core.log
on OA Management Node:
Jan 3 10:58:45.973 : DBG [UI:90ee8791:1305073:1483437523899 1:4342:f2cebb70 PACI ]: [ PACI::PACI_HN_INFO_impl::registerIPAddress] [REGISTER] IP address [10.37.131.2] for interface [br1]
Jan 3 10:58:46.013 : DBG [UI:90ee8791:1305073:1483437523899 RequestProcessor-35108 pau ]: c.p.p.tracer exit by exception: com.parallels.pa.service.ip.ejb.IPAddressManagerBean.registerIPAddressPlesk.ErrorHandling.IPManager.IPAlreadyConfigured: IP address 010.037.131.002 is already configured with id #132.
Cause
There is a discrepancy between network adapter names and asssigned IPs on the OACI hardware node and the corresponding records in Odin Automation.
2 known cases are common:
- 2 or more brX adapters with the same vitrual IP address (like 10.37.131.1) existing on the hardware node
- OA contains records about br1 interface and the hardware node contains br2 interface
Resolution
Note: the actions below interrupt network connectivity of Virtual Environments that have network adapters attached to the bridge devices getting fixed. In order to minimize the impact, it is advised to stop all Virtuozzo services (with all VEs) before proceeding:
Virtuozzo 7.0:
# systemctl stop prl-disp
# systemctl stop vz
Virtuozzo 6.0:
# service parallels-server stop
# service vz stop
Case 1
Recreate the virtual network with another IP that does not exist in the system, binding it to the same network interface. In case the adapter already exists in OA, use the same IP.
[root@gin ~]# vznetcfg if list | grep br
br1 bridge VNET2 10.37.146.1/24,fdb2:2c26:f4e4:1::1/64,fe80::6c99:3dff:fe03:cb1b/64
# prlsrvctl net info VNET2
Network ID: VNET2
Type: bridged
Bound To: bond1.2002
# prlsrvctl net del VNET2
# prlsrvctl net add VNET2 --ifname bond1.2002 --type bridged --ip 10.37.146.2/24
Case 2
It is required to contact Odin Technical Support to apply the resolution.