Symptoms

A vendor has some Service Plan having a "Yearly" Billing Period delegated to his resellers. When trying to change some plan's parameters other than "Billing Period Type" or "Recurring Type" (for example, plan's name, description, auto-renewal settings, etc.), an error message is shown:

This Plan has been delegated to Resellers. You are not allowed to modify Billing Period Type.

Cause

The service plan has in fact not a "Yearly" Billing Period but a custom one for 12 months. When such Service Plan is altered, the system tries to set the Billing Period to "Yearly", but since the plan is delegated it is not possible to complete this operation.

This behavior is acknowledged as incorrect and a software issue with ID PBA-83083 was submitted to the developers to correct it. Contact your Technical Account Manager or Pooled Technical Associate Team at pta@odin.com to clarify the status of #PBA-83083.

Resolution

To be able to make modifications to such Service Plans, it is possible to set the Billing Period value to "Custom: 12 months" along with the desired changes.

Internal content

Link on internal Article