Symptoms
Staff member of a customer account can see only a few subscriptions in the drop-down subscriptions list in CCP (v1), while other account staff members can see all the subscriptions.
Cause
Access was limited here:
CCPv1 > Account > Admins > USER > Manage Advanced Settings > Managed Subscriptions
By default admin (user with role Account Administrator) has no restrictions and he is able to manage all subscriptions of own account:
As soon as list of managed subscriptions is set (contains even a single subscription) user has access only to subscriptions in the list.
Resolution
Adjust list of managed subscriptions.