Symptoms
Task "Provisioning "Tenant" for APS application Azure Cloud Solution Provider"
fails:
"error": "400",
"message": "Access denied.",
"category": "service",
"context": "401",
azure.log
error:
ERROR [com.odin.azure.api.PartnerCenter] (azure task-18) Partner service failed response:{"code":400,"description":"Access denied.","data":[],"source":"PartnerFD"}
DEBUG [com.odin.azure.api.PartnerCenter] (azure task-18) <CREST> Request failed: [com.microsoft.store.partnercenter.exception.PartnerException] {"code":400,"description":"Access denied.","data":[],"source":"PartnerFD"}
ERROR [com.odin.azure.server.ErrorsHandler] (azure task-18) <APS-APP> Error: com.odin.azure.api.exceptions.PartnerCenterErrorException: Access denied.
Cause
The error itself, returning by Microsoft API is generic.
The most possible reason is: customer removed Delegated Admin Permissions (DAP), related to the Reseller on the Microsoft Partner Center side.
Resolution
Check the Company Info
section of the mentioned customer on the Microsoft Partner Center side. In case Partner Relationship is revoked, one can see corresponding notification.