Symptoms
1) A customer has several subscriptions provisioned, the data between OA and BA is consistent. However, these subscriptions are not displayed on CCPv2 subscriptions summary screen at CCPv2 > Account > Subscriptions. The message No data
is shown instead;
2) The tab VPS is loading infinitely. In the browser debug console the failed request as below is registered:
https://cp.example.com/aps/2/resources/$UID_of_BA_resource/sm/subscriptions?and(sort(-subscriptionId),limit(0,40))
This request can be found in core.log
finished with 500 Internal Error
and with the following stack trace:
com.parallels.pa.service.bss.sm.ejb.SubscriptionManagementProxyBean.listSubscriptionsWithTaxesjavax.ejb.EJBException: Unreachable code
at com.parallels.pa.service.bss.sm.domain.Subscription.getPlanPeriod(Subscription.java:407)
at com.parallels.pa.service.bss.sm.rest.BssSubscription.<init>(BssSubscription.java:205)
at com.parallels.pa.service.bss.sm.rest.BssSubscription.<init>(BssSubscription.java:233)
at com.parallels.pa.service.bss.sm.ejb.SubscriptionManagementProxyBean.listSubscriptions(SubscriptionManagementProxyBean.java:570)
at com.parallels.pa.service.bss.sm.ejb.SubscriptionManagementProxyBean.listSubscriptionsWithTaxes(SubscriptionManagementProxyBean.java:269)
Any of "Running" subscriptions could be obtained via the request:
https://localhost:6308//aps/2/resources/dfee9d16-a1b5-4d14-b2cb-928d9ea63a89/sm/subscriptions?eq(subscriptionId,1003109),limit(0,1)
1) Customer also has several subscriptions in "Terminated/Removed" status and they are not available with the query above.
2) "PlanPeriod" was removed from plan manually in Billing Database.
Cause
One or several subscriptions have been created via BA API with predefined parameters of "Period" and "PediodType" which do not correspond with the values defined in their plan properties.
Resolution
Please contact Odin Technical Support in order to resolve the inconsistency.