Symptoms
In Home > System > Settings > Customer CP > Redirect Settings > New Subscription link to online store is setup (e.g. https://store.hostname.tld). However after choosing the service plan and reaching the checkout screen, the white screen is shown. Browser console shows exception:
Failed to execute 'postMessage' on 'DOMWindow': The target origin provided ('https://undefined') does not match the recipient windows's origin (https://store.hostname.tld)
It works if Target is set to Whole Window
.
Cause
On-line store does not work in frame without proper redirect.
Resolution
The following configuration can be used:
Create a redirect Home > Products > Online Store > Direct Links
the redirect to the main page will look like
NAME_PATH=
- Synchronize the store
- Choose this newly created redirect link in Home > System > Customer CP > New Subscription (CCP v1), you can use Main Frame in that case.