Symptoms

After new localization package (.po file) is uploaded on the Addons tab, new localization strings are not applied.

Cause

The improvement request APS-39337 has been submitted to CloudBlue R&D team regarding this behavior.

Resolution

* For UI service running on the management node:*

  1. Customization of a view or tab label (these are present in po files as well as mentioned in APP-META.xml) requires restart of CloudBlue Commerce services on the Management Node to apply changes.

  2. Customization of any other string that is not a view or tab label (like a notification or some message on the APS Application screen) does not require any actions and will be applied right away.

  3. Customization of any string to "" (NULL) or " " (space) will lead to the following situation: next changes of the same string will not be applied until the version of locale APS package with "" or " " will be removed from PCP > Services > Applications > app_name > Add-ons > app_name - localization xx_XX > Versions.

* For UI service running on a branding node:*

  1. Customization of a view or tab label (these present in po files as well as mentioned in APP-META.xml) requires simple pau restart on UI node:

    # service pau restart
  2. Customization of any other string that is not a view or tab lable (like a notification or some message on the APS Application screen) requires removal of Apache cache:

    # rm -rf /var/cache/brands/*

    no need to restart httpd.

Please contact your Technical Account Manager or a member from Pooled Technical Associates to trace the status of the request.

NOTE 1: In case of doubts which resultion path to follow, please restart CloudBlue Commerce services on CloudBlue Commerce MN, remove brands cache on Branding UI, restart CloudBlue Commerce services on Branding UI and clear browser cache. In case if the issue persist, please contact CloudBlue technical support for further investigation.

NOTE 2: References in the translation entity (e.g. '#: APP-META.xml') are not required, however they are present if .po file was generated.

Please refer to the following KB article for the instructions on how to restart CloudBlue Commerce services correctly:

How to restart CloudBlue Commerce system services: UI, Management Node, Agents

Internal content