Symptoms

  1. Attempt to set administrator credentials for Cloud Store instance fails with :

    Could not set Cloud Store Access: null null
    
  2. The following error may be found in cloud-store-app.log:

    07-09-2017;21:05:19.345 [pa-rest task-185] DEBUG c.p.p.c.i.c.r.d.CloudStoreService - Set Store Access Restriction, storeUuid: f15d7a7a-a055-4775-965d-74dccfc67324
    07-09-2017;21:05:19.346 [pa-rest task-185] DEBUG c.p.p.c.i.c.s.e.CloudStoreProvisioningBean - Start set cloud store access restriction, storeUuid: f15d7a7a-a055-4775-965d-74dccfc67324
    07-09-2017;21:05:19.349 [pa-rest task-185] DEBUG c.p.p.c.i.c.store.api.CloudStoreDTO - Set provisioning state, storeUuid: f15d7a7a-a055-4775-965d-74dccfc67324, state: FINISHED
    07-09-2017;21:05:19.350 [pa-rest task-185] DEBUG c.p.p.c.i.c.pem.ejb.PEMManagerBean - Adding file: .htpasswd to brand: 127
    07-09-2017;21:05:19.382 [pa-rest task-185] ERROR c.p.p.c.i.c.pem.ejb.PEMManagerBean - Exception while adding file to brand
    java.lang.IllegalStateException: null
    null
            at com.parallels.pa.customer.ingram.cloudstore.openapi.OpenAPIFacade.call(OpenAPIFacade.java:265) ~[classes:na]
            at com.parallels.pa.customer.ingram.cloudstore.pem.ejb.PEMManagerBean.addFileToBrand(PEMManagerBean.java:151) ~[classes:na]
            at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[na:1.8.0_112]
    

Cause

Brand, corresponding to Cloud Store instance was recreated, its ID changed. However, ID of brand remained unaltered in Cloud Store configuration DB tables. That led to the situation when non existent brand was being updated.

The situation will be fixed in the scope of the software issue APS-43091.

Workaround

Contact Odin Technical Support to work around the issue.

Internal content

Link on internal Article