Symptoms

A periodic task Synchronize resource usage for APS application instance #XXX fails with the following output:

Could not get resource usage for resource with UUID 'b69c6390-6094-41fe-9d68-75fec1147b72': Could not invoke endpoint url 'https://192.168.10.15:443/O365App01/aps/tenants/b69c6390-6094-41fe-9d68-75fec1147b72' of application instance with UUID 'd6c8a71b-37d8-4b8a-a578-c19b44691170'. {
"code": 500,
"message": "Value cannot be null.\r\nParameter name: g",
"additionalNonlocalizableMessage": ""
} Could not get resource usage for resource with UUID 'b69c6390-6094-41fe-9d68-75fec1147b72': Could not invoke endpoint url 'https://192.168.10.15:443/O365App01/aps/tenants/b69c6390-6094-41fe-9d68-75fec1147b72' of application instance with UUID 'd6c8a71b-37d8-4b8a-a578-c19b44691170'. {
"code": 500,
"message": "Value cannot be null.\r\nParameter name: g",
"additionalNonlocalizableMessage": ""
}

where the resource with uuid b69c6390-6094-41fe-9d68-75fec1147b72 is a resoruce of type http://www.parallels.com/Office365/Tenant/1.x.

Cause

The reseller purchased Office 365 resources from the provider via subscription based on a service template with enabled autoprovisioning (Power Reseller model is used). As a result, an Office 365 tenant resource was automatically provisioned on the reseller's subscription with empty properties. The properties like initial_subdomain, ms_account_id and others are missing:

# curl -kE /usr/local/pem/APS/certificates/poa.pem  https://localhost:6308/aps/2/resources/b69c6390-6094-41fe-9d68-75fec1147b72
{
        "aps":
        {
                "type": "http://www.parallels.com/Office365/Tenant/1.7",
                "id": "b69c6390-6094-41fe-9d68-75fec1147b72",
                "status": "aps:ready",
                "revision": 7,
                "modified": "2017-08-18T12:44:05Z",
                "subscription": "87e29a58-10f4-4964-93e8-002e60efeb61",
                "schema": "/aps/2/types/488",
                "package":
                {
                        "id": "9e657681-1704-4646-af79-e845ec356bb0",
                        "href": "/aps/2/packages/9e657681-1704-4646-af79-e845ec356bb0"
                }
        },
        "format_phone_numbers_during_sync": false,
        "is_activated": "yes",
        "totalPointsSold":
        {
......

The APS resource of the reseller's subscription:

# curl -kE /usr/local/pem/APS/certificates/poa.pem  https://localhost:6308/aps/2/resources/87e29a58-10f4-4964-93e8-002e60efeb61
{
        "aps":
        {
                "type": "http://parallels.com/aps/types/pa/subscription/1.0",
                "id": "87e29a58-10f4-4964-93e8-002e60efeb61",
                "status": "aps:ready",
                "revision": 2,
                "modified": "2016-12-19T12:10:19Z",
                "schema": "/aps/2/types/67",
                "package":
                {
                        "id": "7b329ebb-a7df-4fad-ad91-026aa1b91cfe",
                        "href": "/aps/2/packages/7b329ebb-a7df-4fad-ad91-026aa1b91cfe"
                }
        },
        "subscriptionId": 1009055,
        "trial": false,
        "disabled": false,
        "description": "Reseller Office 365 Resource Pack",
        "name": "Reseller Office 365 Resource Pack",
        "serviceTemplateId": 123,
......

Resolution

The issue could be prevented by setting autoprovisioning to No at OA > Products > Service Templates > service_template_name > General > Edit reseller's subscription creation. Note that service templates inteded for the Power Reseller mode should not have Autoprovisioning enabled.

In order to fix the issue, the incorrect tenant APS resource has to be deleted. Please contact Odin Technical Support in order to apply the solution.

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