Symptoms

The provider's staff member gets logged in to CCP v2 on behalf of customer's user ('login as' link) and tries to cancel the customer's subscription from CCP v2. An attempt results in the error message:

Access Denied.

Cause

An option "Allow to Cancel Subscriptions in CCP v2" is set to "Disabled" for the role assigned to the user on behalf of whom the operation is initiated.

Resolution

Either cancel the subscription from PCP/RCP or give the user permission to cancel subscriptions from CCP v2 by adding different role or modifying the existing one in System > Settings > Security > Roles > Customer roles > affected role > Privileges

The reason for button presence is described in the article https://kb.cloudblue.com/en/131309. The button is absent when the user gets logged to CP directly.

Internal content