Symptoms

There is a discrepancy between date/time displayed in PCP/CCPv1/UX1 and the time when the corresponding events occurred. The time is in sync on all the nodes of OA infrastructure.

The following usecases could be observed (not limited to them):

  • whenever a user attempts to reset a password, the error is shown:

    This link is invalid or has expired
    
  • events time in Task Manager -> Cloud Infrastructure log does not match the real events;
  • incorrect time in Cloud Infrastructure performance graph.

/etc/localtime file is either linked to:

[root@osscore ~]# ls -alh /etc/localtime
lrwxrwxrwx 1 root root 26 Aug  1 02:47 /etc/localtime -> ../usr/share/zoneinfo/Host

or is not a link at all:

[root@osscore ~]# ls -alh /etc/localtime
-rw-r--r-- 1 root root 1.2K Sep 14  2016 /etc/localtime

Cause

Java application server relies on the correct link of /etc/localtime file in order to calculate date/time in its functions. Malformed link may cause discrepancies between the actual time on the server and the time Java uses.

Improvement request POA-112298 has been submitted to catch such discrepancies during OA update prechecks.

Resolution

Recreate the correct to the required time zone on the Management Node:

# rm -f /etc/localtime
# ln -s /usr/share/zoneinfo/Europe/London /etc/localtime
# service pa-agent stop && service pau restart && service pa-agent start

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