Symptoms

While performing the Syndication to CSP transition for a large Office 365 account (with a lot of subscriptions, based on various service plans), the error could be faced on running the completeMOSI2CSP.py script:

Unable to prepare the import data because of error: The operation has timed out

sitelog from the endpoint shows PlansForSubscrList API call to Billing without response.

Cause

The default timeout for communications from CSP endpoint to Billing API is 100 seconds. It could be insufficient to process a large account. The behavior is going to be improved in scope of issue APSA-18327.

Resolution

  1. Backup the App_Code\pba\PBAOpenAPI.cs file from the Office 365 endpoint website. Do not put it into the same directory!
  2. Edit the file and find the spot:

    var proxy = XmlRpcProxyGen.Create<TPBAOpenAPI>();
    proxy.Url = _url;
    foreach (var logger in _loggers)
    {
            logger.SubscribeTo(proxy);
    }
    
  3. Add the line with proxy.Timeout:

    var proxy = XmlRpcProxyGen.Create<TPBAOpenAPI>();
    proxy.Url = _url;
    proxy.Timeout = 5 * 60 * 1000;
    foreach (var logger in _loggers)
    {
            logger.SubscribeTo(proxy);
    }
    
  4. Restart IIS web server: run iisreset in command prompt.
  5. Re-run the completeMOSI2CSP.py script.

Internal content