Symptoms
Provisioning "Subscription" for APS application Office 365
task fails:
"code": 500,
"message": "Suspension reason in request does not match suspension reason on subscription.",
An attempt to activate previously suspended subscription could be found in the server.log
:
POST https://api.cp.microsoft.com/2c003aac-ec92-4f0e-afff-78b89ec5842d/subscriptions/5dc8de3c-1314-4b84-8fd0-4527daaa3cfc/remove-suspension
...
{"state":"Active","suspension_reason":"CustomerCancellation"}
However, this subscription has another suspension_reason value according to the server.log:
INFO [com.parallels.poa.csp.crest.ejb.LoggingFilter] (default task-15) * Response received on thread default task-15]
...
"suspension_reasons":["PastDue"]
Cause
suspension_reason value discrepancy between OA and Microsoft Portal.
Resolution
Please contact Microsoft support in order to change the suspension_reason value, since CustomerCancellation is the only one valid value for CSP Partner's subscriptions suspension_reason field.