Symptoms

  1. Go to Online Store;
  2. Choose a Domain Purchase Scenario;
  3. Enter a domain name and click "Search";
  4. Choose any available domain name and click "Next";
  5. Click "Continue".

Redirect to the next page of the Purchase Scenario does not happen.

Cause

Required changes were not done to Layout Templates after hotfix #130369 installation.

Resolution

  1. Go Home > Products > Online Store;
  2. Switch to "Layout Templates" tab;
  3. Find plan_period Layout Template;
  4. Click "Edit";
  5. Replace:

    {capture name="html_name"}
    PeriodPlanID{if $inputname}[{$inputname}]{else}[{$plan.Description.PlanID}][{$addvalue}]{/if}
    {/capture}
    

    With the following:

    {capture name="html_name"}PeriodPlanID{if $inputname}[{$inputname}]{else}[{$plan.Description.PlanID}][{$addvalue}]{/if}{/capture}
    
  6. Return to Summary tab;
  7. Click "Synchronize now".

This change is required because of smarty bug in updated smarty.

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