Symptoms

Office 365 Synchronization/Reconciliation report generation results in following error in CCPv1:

    Unknown error occurred

In a browser debug console the error is:

<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>502 Proxy Error</title>
</head><body>
<h1>Proxy Error</h1>
<p>The proxy server received an invalid
response from an upstream server.<br />
The proxy server could not handle the request <em><a href="/aps/2/resources/f013d363-ebd7-4871-b3da-448cfa29b40c/synchronize">GET&nbsp;/aps/2/resources/f013d363-ebd7-4871-b3da-448cfa29b40c/synchronize</a></em>.<p>
Reason: <strong>Error reading from remote server</strong></p></p>
</body></html>

Cause

Due to a large number of objects to be processes during synchronization, the operation takes significant amount of time on the Office 365 Application Endpoint and the initial UI request times out.

Resolution

  1. Check the current Apache timeout on branding server.

    [root@branding ~] # grep Timeout /etc/httpd/conf/httpd.conf
    Timeout 30
    
  2. Set a new value. The required value may vary, however it usually takes around 5 minutes to process 1000 objects (users, domains and licenses).

    [root@branding ~] # grep Timeout /etc/httpd/conf/httpd.conf
    Timeout 300
    
  3. Correct ProxyTimeout in /etc/httpd/conf.d/brand...

    ProxyTimeout 300
    
  4. Reload Apache configuration to apply changes.

    [root@branding ~] # service httpd reload
    

This behavior has been improved in 18.1 for synchronization, however for Reconciliation report this will be improved in scope of APSA-16066.

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