Symptoms

Logging under a Customer account into CCP the following error can be observed:

Business Automation API is not available now

Upgrade precheck to OSA 7.0 fails with:

Precheck error: Billing Database is corrupted
Do the following: Fix Business Automation system inconsistencies issues. See full issues report at /usr/local/bm/tools/verify_db.log on Billing Application node

/usr/local/bm/tools/verify_db.log lists a great number of database inconsistencies.

Cause

Such issues may be a cause of the rpms inconsistencies.

  1. Go Home > System > Information and check current Product Version:

    Version  6.0.8 
    Build ID 6.0.8-097 
    Built 26-May-2016 
    Installed XX-XXX-XXXX XX:XX:XX 
    
  2. Login to Business Automation Application, Database and Online Store hosts and check versions of Business Automation rpm packages:

    [root@billing ~]# rpm -qa | grep '^bm' |head -n5
    bm-plugin-6.0.9-086.x86_64
    bm-mailmessage-6.0.9-086.x86_64
    bm-domreg-plugin-testregistrar-6.0.9-086.x86_64
    bm-payment-plugin-dummypay-6.0.9-086.x86_64
    bm-xmlsimplelib-6.0.9-086.x86_64
    

The versions discrepancy can be observed.

The issue happened because enabled=0 is missing on the repository configuration:

[root@pbacore ~]# cat /etc/yum.repos.d/pa-central.repo [pa-central-repo] name=PA Central YUM repo for RHEL $releasever baseurl=http://download.automation.odin.com/pa/6.0/RPMS/RHEL/$releasever/ gpgcheck=0

which made bm packages to be updated automatically on running yum update. No update scripts were executed (as they are part of product update, not yum update). The issue is caused by #PBA-64123 "BA packages can be updated automatically by yum".

Resolution

Please contact TAM/pta team to complete update procedure.

Internal content

Link on internal Article