Symptoms

On an installation with either an Acronis Backup Cloud or an Acronis Files Cloud APS application deployed, when accessing the provider's Hosting CP and navigating to the corresponding APS menu on the "More Services" tab, you can randomly see users from different subscriptions and not from the provider's subscription (id=1). Upon refreshing the tab several times the users can change.

Cause

Proper filtering is not implemented in the Acronis APS applications. All the subscriptions that have corresponding APS deployed are fetched in random order when the page is refreshed, and the first of them is being shown.

Resolution

The issue should be fixed in the APS applications. Acronis team should be contacted to address this issue.

Internal content