Symptoms
Transfer of a subscription fails with:
Some of the resources associated with this subscription cannot be transferred
Attempt to check ability to move subscription fails with:
# python /root/pem.checkMoveSubscriptions.py
2017-01-31 06:25:33.594 DEBUG call method pem.checkMoveSubscriptions({'subscription_ids': [1010101], 'new_account_id': 1002001, 'txn_id': '680997385'})
2017-01-31 06:25:34.294 DEBUG return {'status': 0, 'result': [{'sub_id': 1010101, 'is_movable': False, 'dependent_subs': []}]}
2017-01-31 06:25:34.294 INFO Result is [{'sub_id': 1010101, 'is_movable': False, 'dependent_subs': []}]
The subscription has no non-migratable resources, per KB.
In /var/log/pa/core.log
the following message appears:
sc_id 28 returned cause 2 for sub_id 1010101
where 28 is ID of SaaS SC.
The account owns service users with assigned services of APS 2.0 applications from another subscription.
Cause
In case the subscription had services in the past, assigned to some service users by APS application, and later they were deassigned, the subscription transfer fails due to remaining links in APS structure between the subscription and such service users. This is recognized as a software issue APS-40691.
Resolution
Contact your Technical Account Manager or Pooled Technical Associate Team (pta@cloudblue.com) to trace the status of APS-40691 and discuss possible workaround.