Symptoms

Pressing 'Login to Plesk' button in CCP for a 'Plesk in VPS' subscription shows the following error:

Unable to complete the operation, please try again later.

Capturing a more detailed error with web debugger or in /var/log/pa/vps.vm2vf.log on the corresponding hardware node:

Problem with the SSL CA cert (path? access rights?)

There are no certificates (.pem files) found inside the Virtual Environment in /usr/local/aps/<UUID> directory:

[root@server-1000001-1 ~]# find e00a6b18-2dce-4a02-85ac-f42faf61192d -name *.pem
[root@server-1000001-1 ~]#

Cause

For some reason, instance certificates were removed from the affected Plesk in VPS application instance.

Resolution

  1. In case there is a container backup, extract the *.pem files out of it and put them to /usr/local/aps/<UUID>/scripts/config directory.

  2. In case there is no backup and certificates are gone, contact Odin Technical Support to resolve the problem.

Internal content

Link on internal Article