Symptoms

  1. An attempt to change service user password in CCP > Users > 1000001 > General > Change password > Generate new password > Submit fails with the following error:

    An unforeseen error occurred. Please contact support@example.com. 
    Error ID: 1479473282642
    
  2. The following exception can be seen in the /var/log/pa/core.log:

    Nov 18 13:52:36.076 : ERR [rest:64060 1:30690:989e4b70 SAAS 1425930826]: [ APSC] REST Error: PUT /aps/2/application/rest/f145a3ca-40c8-440e-a405-c2f54141786d code=500: Value of property 'notificationEmail' ('') does not match the format 'email': No @ at address
    Nov 18 13:52:36.076 : DBG [rest:64060 1:30690:989e4b70 SAAS 1425930826]: [ HTTP] IN  Response headers: 'Date:Fri, 18 Nov 2016 12:52:36 GMT'  'Connection:Close'  'Content-Type:application/json'  'Content-Length:185'
    Nov 18 13:52:36.076 : INF [rest:64060 1:30690:989e4b70 SAAS 1425930826]: [ HTTP] IN  127.0.0.1  [185] "PUT /aps/2/application/rest/f145a3ca-40c8-440e-a405-c2f54141786d HTTP/1.1"  [0] "500 Internal Server Error"  47ms Actor: ACCOUNT:1012204
    
  3. No e-mail specified in CCP Contact info > Secondary E-mail

Cause

This behaviour caused by the differences in internal logic of Operations Automation in versions 6 and 7. In OA 6.0, empty contact_email was treated as absent contact_email in 6.0, and after upgrade to 7.0 it is not. This software-related issue has been submitted to Engineering Team as internal request #APS-39456.

Resolution

#APS-39456 has been fixed in Odin Automation 7.1.

To resolve the issue for a particular service user:

  1. Set any Secondary E-mail in CCP > Service User > 1000001 > Contact Info > Edit for the corresponding service user and then remove it (if necessary).

  2. Change service user's password.

If whole-installation fix is required, contact your Technical Account Manager or Pooled Technical Associate team at pta@odin.com.

Internal content

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