Symptoms

During processing of task "Change owner of APS subscriptions" panel becomes unstable. For example, after login customers see the following error:

The operation you are trying to perform requires interaction with a component which is presently unavailable.

Every time task is being processed, SaaS service controller crashes and drops coredump.

It making impossible to perform all APS-related operations from PCP and CCP, including new user or service creation - they all fail with:

org.omg.CORBA.COMM_FAILURE: IOException: java.net.SocketException: Socket closed

According to apsc.http.log the following request is the latest:

Begin request: "POST /aps/2/resources/b7b22113-3948-43e8-9257-81cb94ee8842/brand"

In OA's core.log, task stucks in the following methods:

[ APSC] [APS::Controller::addResourceLinks] ===> ENTRY
[ APSC] [APS::Registry::getResourceLinksInternal] ===> ENTRY
[ APSC] [APS::Registry::getResourceLinksInternal] <=== EXIT [0.548363]
[ APSC] [APS::Controller::RESTful::hasReferPermission] ===> ENTRY

There are lots of core files, generated with 5 minute intervals in /usr/local/pem/var/cores.

Cause

"Change owner of APS subscriptions" fails in core dump because of too many identical links between reseller account and brand. In fact, it's singular link from brand to account, which is duplicated.

This situation is identified as software related issue #APS-38918 "Subscription migration fails because of duplicate aps links between reseller account and brand".

Resolution

  1. Cancel all "Change owner of APS subscriptions" tasks temporarily.
  2. Install OA Premium update 7.0.1.
  3. Resubmit tasks cancelled on step 1

If update to 7.0.1 is not possible for some reason, please contact Odin technical support for workaround.

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