Symptoms

The following error is shown when customer tries to change service plan of a subscirption:

    [APS C] Resource for record XXXXX is not found.

Cause

This case has been submitted to the Maintenance Team as internal issue with id APS-17309. The issue can be triggered, if count of DNS resource records in OA DB for the related domain is above 65536.

Resolution

The issue APS-17309 has been fixed in OA 5.5 update 8. However, the error mentioned above can still be shown after installation of update 8. In order to fix it, it is necessary to run the following command on POA Management Node:

# /usr/local/pem/bin/saas_ctl -f /usr/local/pem/etc/pleskd.props sync_account 1 no

It will generate a new task Propagation of APS 2.0 resources for the account #1. After the task is completed, the error should disappear. Please note that the task can run for a very long time (2-3 days or more).

You can find additional information about sync_account utility and its syntax in the following KB article:

#128820 APS2 Account actualization before upgrading to Odin Automation Premium 7.0

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