Symptoms

Billing Control Panel hangs on order placement, which leads to Service Unavailable error after Apache timeout (30 seconds by default).

/usr/local/bm/log/generic_worker.log contains the following errors repetatively:

Operations Automation is not available

OA 8440 port is available from BM, and it is possible to execute API request from Billing Application Node to OA Management Node over HTTP:

# curl -d@api.xml http://192.0.2.2:8440/RPC2
...output is received...

API request over HTTPS hangs:

# curl -d@api.xml https://192.0.2.2:8440/RPC2
...hangs here...

Cause

SSL is enabled on BA side:

select SSL from "PEMOptions";
SSL                      | 1

and disabled on OA side in in System > Settings > Public API.

Resolution

Enable SSL for Public API to allow secure communication between Operations and Billing.

Internal content