Symptoms

Subscription, that has been destroyed on the OA side is in suspended state on the MOP side:

ExtensionData     : System.Runtime.Serialization.ExtensionDataObject
...
SkuId             : 3b555118-da6a-4418-894f-7df1e2096870
SkuPartNumber     : O365_BUSINESS_ESSENTIALS
Status            : Suspended
TotalLicenses     : 5

Office365 TIP Reseller account, application instance settings: Customer Deactivation Behavior = TIP (Test In Production) Account.

Possible consequence of such behavior: next attempt to purchase any concurrent offer in scope of this customer account fails with OfferUseLimitExceeded error message.

Cause

TIP account business logic. The main difference between Production and Test In Production Reseller account types is customer deactivation behavior. In case of TIP Reseller account, the following request sends to MOP in case all customer subscriptions are destroyed on the OA side:

POST https://api.cp.microsoft.com/[Reseller Tenant Id]/customers/delete-tip-reseller-customer
Content-Type: application/json
...
{"customer_id": "<cid-for-customer>"}

Subscription obtains Suspended status on the MOP side when it is destroyed on the OA side if customer has another Active subscription.

Resolution

Contact Microsoft Support to completely destroy the subscription or destroy every subscription, belongs to this account.

Internal content