Symptoms
Office365 import procedure (Importing Tenant Subscriptions from Microsoft Cloud) fails with the following error message in the sitelog
:
Received error response 403 Forbidden:
{"code":"1002","error_code":"Forbidden","object_type":"Error","message":"Reseller CAID does not have a reseller relationship with customer CAID."}
Also, readCSPAccounts.py
returns empty output files.
Cause
Incorrect Partner relationship between the reseller and its customers on the Microsoft Online Portal side. Check the MOP > Partner Center (tile) > Customer Admin Center > Users (left menu item) > Partner Relationship value. readCSPAccounts.py
expects Cloud Solution Provider
relationship type, but it is Advisor
in our case.
Resolution
Change the Partner Relationship type to Cloud Solution Provider
, using the invitation link on the Microsoft Portal and repeat the import procedure.