Symptoms
'Exchange UM 2013' APS application task fails:
Task name
APS application 'Exchange UM 2013', id 217, instance 13129 -> service 'Um_Mailbox', instance 47379: executing configuration script
Last execution output
Application configuration script reported errors: '
error id "INTERNAL_EXCEPTION", setting id "RunspaceException": Internal exception occurred.
Unified Messaging can't validate or generate a UM PIN for mailbox 'user@lync.domain.tld' : An error occurred while accessing the user's mailbox. Details: An internal server error occurred. The operation failed.
at System.Management.Automation.Interpreter.ThrowInstruction.Run(InterpretedFrame frame)
at System.Management.Automation.Interpreter.EnterTryCatchFinallyInstruction.Run(InterpretedFrame frame)'
Cause
Wrong cached data of the corresponding EWS.
Resolution
Check Exchange UM 2013 application instance, related to the problem subscription - it should have
'Ready'
state;Grab the
Originating Server
value from the following cmdlet output:Get-Mailbox -Identity user@lync.domain.tld | fl *
Perform the following cmdlet on mailbox originating server, taken above:
Get-Mailbox -Identity user@lync.domain.tld | Enable-UMMailbox -Extensions 1234 UMMailboxPolicy "MP00[OA_subscription_id]"
In case you get the same error message as in the task output, recycle the
MSExchangeServiceAppPool
application pool on mailbox originating server;- Re-submit the failed task;