Symptoms

O365 users are not syncing. Corresponding user is absent in MOP but present in OA, synchronization script fails after a ~5 minutes with Unknown error occurred:

A communication timeout is being reached (Unknown error occurred)

OA executed the following query and got the result only after 1 hour:

Jul  2 09:40:46 osscore.domain.com : DBG [rest:219937 1:24116:dc906b70 SAAS ]: [ RDBMS] Prepare     [0xe52b74e8]: SELECT "id" FROM "aps_resource" WHERE "uid" = $1 FOR UPDATE
Jul  2 09:40:46 osscore.domain.com : DBG [rest:219937 1:24116:dc906b70 SAAS ]: [ RDBMS] Execute     [0xe52b74e8]: 503d9923-7589-4895-9bf0-f3d46ac07468
Jul  2 10:42:00 osscore.domain.com : DBG [rest:219937 1:24116:dc906b70 SAAS ]: [ RDBMS] Fetch     [0xe52b74e8]: 166559

Timeout has been reached for the request at APS endpoint side and following error was shown:

2015-07-02 09:45:46,707 [  35] ERROR aps_endpoint: Outgoing request 6c613197-5b3d-45ad-a998-c9caa8e63cbe: response error
System.Net.WebException: The operation has timed out
at System.Net.HttpWebRequest.GetResponse()

As a result unknown error was displayed in CCP.

Cause

Deadlock happened between aps_resource and aps_account_context tables. Both tables were locked FOR UPDATE. The issue has been reported to the development team in scope of the request APS-27909: Subscription creating via API: PSQLException: deadlock detected and fixed in OA 6.0 update 5.

Resolution

Please update your environment to OA 6.0 update 5 or later. As a workaround it is necessary to restart pem, pau and PostgreSQL services on OA Core server.

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