Symptoms

An attempt to reset MOP admin password performed when tenant is not ready yet - as a result the task Provisioning "Subscription" for APS application Microsoft Office 365 fails with the following error and not rescheduled:

APS Application Error:
500 Internal Server Error
[ApplicationUnknownError] Provisioning: resource 1de14761-5888-4bb6-8ece-e3bf32030af0 of type 'subscriptions' (http://www.parallels.com/Office365/Subscription/1.2) for APS application 'Microsoft Office 365-6.3-48': The TenantID you have provided is invalid. Check the TenantID and try again. (Microsoft.Online.Administration.Automation.CompanyNotFoundException,Microsoft.Online.Administration.Automation.SetUserPassword).

Body: { "code": 500, "message": "The TenantID you have provided is invalid. Check the TenantID and try again. (Microsoft.Online.Administration.Automation.CompanyNotFoundException,Microsoft.Online.Administration.Automation.SetUserPassword)", "additionalNonlocalizableMessage": "","error":"ApplicationUnknownError","http_request": "POST /O365App/aps/subscriptions to '127.0.0.1'"

Cause

APSA-13400: Attempt to reset MOP admin password perfromed when tenant is still not ready.

Resolution

The issue has been fixed in Office365 6.4 in scope of the request APSA-13400. Please update Office365 to version 6.4 to fix the issue completely. To workaround the issue to existing tasks, restart the failed tasks after tenant provisioning is completed.

Internal content