Symptoms

Office365 subscription synchronization fails with the following error:

Error: Object with id = xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx not found

Cause

Subscription (or customer account) was never provisioned to Microsoft, and it is absent in MOSI database.

Resolution

In case the application under the subscription in question is in Waiting for the default subdomain to be specified status, please apply the instructions described in the following chapter of the documentation (step 3): Configuring Office 365 Subscription > Installing Application

Otherwise, check unprocessed or cancelled tasks, related to this subscription to identify the reason why it has not been provisioned yet.

Internal content