Symptoms

Office365 executing configuration script task fails with the following output:

<StatusCode>InternalServerError</StatusCode>
<StatusDescription>Internal Server Error</StatusDescription>
<s:Reason>
<s:Text xml:lang="en-US">ServiceUnavailableFault</s:Text>
</s:Reason>

Cause

APSC request was not able to reach MOP.

Resolution

First of all, check that gateway IIS site (and corresponding application pool) on MOSI GW server is up and running. Otherwise, restart it manually.

If it does not help, please contact Microsoft Support, providing the following log files:

  1. Sitelog: C:\inetpub\wwwroot\mosi\App_Data\sitelog
  2. XMLPayload related to the customer in question: C:\inetpub\wwwroot\mosi\App_Data\XMLpayload\customer1234.log
  3. log with increased verbosity, it can be done using the article How to enable verbose log on MOSI Gateway Host
  4. XML requests C:\inetpub\wwwroot\mosi\App_Data\web_messages.svclog and C:\inetpub\wwwroot\mosi\App_Data\web_tracelog.svclog

Internal content