Symptoms

Placing a sales order for Softlayer APS service plan, the second screen shows the error:

There has been an error getting product list, contact your admin to solve it

This occurs for one of the configured brands and doesn't happen for another one.

Cause

The branded CP URL should be allowed in the configuration of the Sofltayer APS instance.

Resolution

  1. Go to Softlayer APS instance configuration.
  2. Open 'Branding List' screen.
  3. Add/edit the brand.
  4. Add the required URL to the list of allowed URLs.

Internal content