Symptoms

The task Provisioning "Migration" for APS application Office 365 fails with Unable to synchronize domains and users from the Cloud to PA, the task is generated for import of existing CSP For example the task may fail with the following error:

[ApplicationUnknownError] Provisioning: resource 434d8a6c-6637-41af-9a45-4e9e0cbf875a of type 'migrations' (http://www.parallels.com/Office365/Migration/1.1) for APS application 'Office 365-6.4.1-8': Unable to synchronize domains and users from the Cloud to PA. Please resolve an issue and restart the task. Error details: Error: We've found more users with CRMSTANDARD license than subscriptions limit. This might be caused by the Office 365 subscriptions obtained elsewhere. Note that user assignments cannot be managed for those subscriptions in this control panel.

Please note that the offer in error message may differ.

Cause

The error may occur if tenant has Office 365 licenses obtained from other CSP partner which are assigned to users in Microsoft Online Portal.

Office 365 APS application does not handle such situation during subscription synchronization. Such behavior will be reworked in scope of internal request with ID APSA-14590.

Resolution

Please contact your TAM or PTA to trace the status of APSA-14590. Until it is fixed you may use the following workaround to process the task:

  1. Open subscription in question under Provider CP > Subscriptions and switch to Resources tab;
  2. Increase the limit for resource representing offer mentioned in task output. New limit should be equal the amount of users with problematic offer license assigned;
  3. Restart the task.

Note: you should keep in mind that you or end-customer may be charged by Microsoft for extra-licenses ordered in Microsoft cloud because of such workaround.

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