Symptoms

Office365 sync script fails with the error:

2015-08-03 14:51:34,997 ERROR   Subscription 1234567: error by data comparison: not well-formed (invalid token): line 2, column 281
2015-08-03 14:51:34,999 ERROR   Traceback (most recent call last):
File "/officesync/O365-Import4-16-11/import_csv.py", line 1391, in compareSubscriptions
poaSubs.loadAppSettings()
File "/officesync/O365-Import4-16-11/import_csv.py", line 746, in loadAppSettings
self.account_id = self.api.pem.getSubscription(subscription_id = int(self.subId), get_resources = False)["owner_id"]
File "/officesync/O365-Import4-16-11/modules/openapi.py", line 145, in __call__
resp = getattr(self.api.server, self.name)(params)
  File "/usr/lib64/python2.4/xmlrpclib.py", line 1096, in __call__
return self.__send(self.__name, args)
  File "/usr/lib64/python2.4/xmlrpclib.py", line 1383, in __request
verbose=self.__verbose
File "/usr/lib64/python2.4/xmlrpclib.py", line 1147, in request
return self._parse_response(h.getfile(), sock)
  File "/usr/lib64/python2.4/xmlrpclib.py", line 1281, in _parse_response
p.feed(response)
File "/usr/lib64/python2.4/xmlrpclib.py", line 527, in feed
self._parser.Parse(data, 0)
ExpatError: not well-formed (invalid token): line 2, column 281

Cause

symbol in the name of OA subscription due to APSA-12272.

Resolution

Please contact your TAM or PTA to trace the status of APSA-12272. To workaround the issue, please remove the problem symbol from subscription's name and repeat the sync attempt.

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