Symptoms

Recently one of our brands was migrated to NG hosting. Before migration it has more locales in interface settings, but now I can select only English. Why?

Cause

Language Pack (LP further in the text) package was not installed on NG node.

Resolution

Please refer to the page 10 of the guide http://download.automation.odin.com/poa/5.5/doc/60112_1.htm for details:

4 Install the LP package to all web servers within web cluster on which UI is enabled. Note: Skip this step if you have only VPS - based or Hardware Node - based UI servers.

    a Obtain ID of a required language package. To do this:
    • Go to Infrastructure > More > Package Repository in the Packages group.
    • To filter packages use the lp* mask in the Name field.
    • Write down ID of the required package. 

    b Obtain IDs of the web servers to install LP to.

    For Web Cluster:
    • Go to Infrastructure > Clustering > Web Clusters.
    • Click on the required cluster's name.
    • Write down the IDs from the Web Servers section.

    For Web Server NG:
    • Go to Infrastructure > Hardware Nodes.
    • Find the required web server and write down its ID.

    c Log in to POA management node.

    d Perform the following command:

    # /usr/local/pem/bin/ppm_ctl install <host_id> <pkg_id>

5 Enable the new language in the interface settings of all your brands.

    a Go to each brand’s management page ( System > Settings > Brands in the Branding group > brand name).
    b On the Interface Settings tab, click Edit.
    c Select the new language in the Localization area of the screen.

For details on configuring other interface localization options, refer to topic Managing Brand Interface  Settings.
Repeat the procedure for all brands, for which you wish to enable the new language.

Internal content