Symptoms
An order to change the service plan failed with an error:
Change Service Plan failed: There is already a Change Order #CHID in Status Completed(CP). This order prohibits the 'Change Plan Period for Subscription' action. Please either cancel conflicting order or wait until it is processed; or contact Provider.
There is indeed an order CHID
, which is successfully completed, all the provisioning items have completed status.
Cause
An order to change the service plan was created earlier than order #CHID provisioning completed. Usually it is not possible to place a second change order on the same subscription unless the first one is completed, but there is a bug with id #PBA-57940 ("PlaceResourceUpgradeOrder_API does not detect conflicted upgrade orders") due to which order placement is possible with API.
Resolution
Cancel the current order to change the service plan and place a new one, it is expected to be completed successfully.