Symptoms

Customer is unable to access webmail with the following error:

LGI-0006 Categories=USER_INPUT Message='Invalid credentials.' exceptionID=-385885892-655938

The webmail page redirects to CCP and the following error is shown there:

An unforeseen error occurred. Please contact support@hostname.tld.
Error ID: 1445295710604

/var/log/open-xchange/open-xchange.log.0 contains the following error:

2015-10-24T04:56:41,045-0400 ERROR [OXWorker-0192839] com.openexchange.custom.parallels.impl.ParallelsOXAuthentication.handleLoginInfo(ParallelsOXAuthentication.java:245)
Error in loading user or context from loginstring mailbox1@hostname.tld from OX API
...
com.openexchange.exception.OXException: LGI-0006 Categories=USER_INPUT Message='Missing user mapping for user "hmailbox1@hostname.com". Login failed.' exceptionID=-385885892-669107

Changing OX account passwords does not work: tasks to change the password complete successfully, but they are not actually updating the users LDAP credentials and user is unable to access the mail account.

Cause

Incorrect mappings appeared in Open-Xchange context as a result of canceled tasks in the past.

Resolution

Note that the mailbox is mailbox1@hostname.tld, but the mapping mentioned in the error refers to mailbox1@hostname.com. To remove such mappings, first list the context using the command:

# /opt/open-xchange/sbin/listcontext -A oxadminmaster -P *** -s *mailbox1* --csv 

Then remove incorrect mappings using the command like:

# /opt/open-xchange/sbin/changecontext -A oxadminmaster -P  *** -c <context_id> --removemapping "mailbox1@hostname.tld||mailbox1@hostname.com"

Note: oxadminmaster password can be retrieved from global settings of 'Open-Xchange' application resource type in OA CP.

Internal content